By continuing to use this site, you agree to our use of cookies. Find out more

Problem with Axminster Woodturning Lathe

All Topics | Latest Posts

Search for:  in Thread Title in  
Martin Leeks28/12/2019 20:47:43
3 forum posts

I have just been given a 20 year old APTC M950 lathe. All seems to be in good order and the lathe turns manually without any issues and the belt looks almost new.

However, when I press the starter button the lathe momentarily begins to turn but then almost immediately my fuse box trips (my workshop runs a high powered welder without issue so I don't think it draws too much power).

Anyone got any ideas where I start to fix this ?

Thanks for any help.

Derek Lane29/12/2019 11:27:56
avatar
Moderator
3219 forum posts
1004 photos

Unplug and then have a look in the switch box and see if there is a build-up of dust in there, even though it may seem sealed worth doing and cleaning out use a vac if you can. Check any wiring for damage.

If the above fails then go with my comment below.

I think that the electrics need looking at by a qualified electrician

Martin Leeks29/12/2019 13:48:13
3 forum posts

Many thanks Derek. I'll try that and see what happens.

Derek Lane29/12/2019 14:01:24
avatar
Moderator
3219 forum posts
1004 photos

Hope you sort it soon

Ron Davis29/12/2019 16:23:41
avatar
1619 forum posts
201 photos

I have the M950, now 21 years old, and I had exactly that problem with it, I took the head stock back to the suppliers and they replaced to head stock after it blew their fuse as well. Derek's idea is probably the best place to start, if you can manage the basic electricity skills, the why not buy a new switch? You should get the details from the old one and there are plenty on the various auction sites.

Martin Leeks29/12/2019 17:40:06
3 forum posts

The switch box is super clean and all the connections look solid. I need to dig out my multimeter and check whether there is any issues with the switches though. There is a centrifugal switch but it looks OK with no marks or charring on it. The motor itself looks really dirty though with a lot of wood dust inside the casing, I haven't tried to take it apart yet but will try to vacuum it out as best I can, as I'm not sure how easy it will be to take the whole thing to pieces.

Don't really want to spend money on an electrician until I've tried everything I can.

Cedric Wheeler30/12/2019 20:52:08
154 forum posts
31 photos

This sounds to me that it is the starter capacitor which is probably not working. this is a tubular unit usually bolted to the outside of the motor. You might also try spinning the job in your lathe by hand & then press your starter while it is rotating. If the motor then runs it is definitely the capacitor.

Cedric

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of The Woodworker & Good Woodworking? Use our magazine locator links to find your nearest stockist!

Find The Woodworker & Good Woodworking 

Latest Forum Posts
Support Our Partners
Triton
Peter Sefton IMPROVE FAST LONG
Robert Sorby
Transwave 2017
Wood Workers Workshop
Craft Supplies
Felder UK April 2016
Tormek
Turners Tool Box
D B Keighley
Chippendale
D&M Tools
Subscription Offers

Subscribe to<br />    The Woodworker Magazine and receive a FREE gift

Contact Us

We're always happy to hear from you, so feel free to get in touch!

Click here to find who to contact